It is currently 19 Oct 2017 6:08


Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: 13 Jun 2007 4:26 
Offline
Nouveau
Nouveau
User avatar

Joined: 13 Jun 2007 12:00
Posts: 2
Location: Tallahasse, FL USA
I'm trying to execute an MSSQL ssis package from a Control-M job.

I use the command line format to execute the dtexec utility....

dtexec /SQL [server] / [package]

The problem is that the connections in my package are defined using Windows Integrated security. When the package tries to connect, I get a login error with the user identified as "NT Authority/Anonymous Logon".

I has assumed that the domain account that I am using to run Control-M would be passed to the package but this does not seem to be the case.

Using SQL Server authentication on my package connections does work, but I prefer to use Integrated security.

Is it possible? And how can I do it?

Thanks.


Top
   
 Post subject:
PostPosted: 14 Jun 2007 12:50 
Offline
Nouveau
Nouveau
User avatar

Joined: 26 Feb 2007 12:00
Posts: 43
Hi,

There is an option in Control-M Agent menu logon as user, you need to select it and also domain name.

Once done recycle the Control-M Agent services.

hope this helps...


Top
   
 Post subject:
PostPosted: 19 Jun 2007 11:12 
Offline
Nouveau
Nouveau
User avatar

Joined: 13 Jun 2007 12:00
Posts: 2
Location: Tallahasse, FL USA
Actually, it turned out to be the old NTLM double hop situation. Worked around it by reconfiguring my package connections (which reference a second server) with SQL Server authentication.


Top
   
 Post subject:
PostPosted: 20 Jun 2007 6:56 
Offline
Nouveau
Nouveau
User avatar

Joined: 08 Jun 2007 12:00
Posts: 807
Location: Varese - Italy
Use the "log as user" and in the job definition indicate a user that can connect to the target machine and still connect to the DB.
In the Ms sql server i have tried to use windows authentication but dont work. But in my case the DB was on a remote host, not on the machine were i have the agent installed.

To see the configuration for the "logon as user" settings see page 27-28 on the agent administration guide, and in windows remember to add "run batch jobs" to the user policy.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC+02:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited
The site created by Franck YOT. Images, logo, content and trademarks about Control-M products are property of BMC Software.
All the comments are property of their posters. Images, logo, content and design are © copyright by Scheduler-Usage.com. All Rights Reserved