It is currently 22 Sep 2018 1:55


Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: 30 Jul 2018 12:06 
Offline
Nouveau
Nouveau

Joined: 30 Jul 2018 11:58
Posts: 1
Hi,

I have a shell script (Linux) whith a php cli which always failing with ControlM.

ODATE=$1
echo "The user executing is `whoami`"
echo "Path is `pwd`"
echo "Running php program"
echo "Odate is $ODATE"

/opt/php/php7_installed/bin/php -c /opt/php/php7_installed/lib/php.ini /servicios/vertriebsmanager/export/erfolgsreporting_cr_sb.php
ret=$?

if [[ $ret -ne 0 ]];
then
echo "ERROR IN PHP"
exit 2;
fi

When I execute the shell script manually it works. In ControlM the script fails.

The php scripts works with a db class (Oracle via ODBC).

include ($HAUPTLINK_VM.'xx_klassen/db_class_'.$db.'.inc'); --> here it fails via controlm.

Has anybody an idea why?


Top
   
PostPosted: 14 Aug 2018 12:50 
Offline
Nouveau
Nouveau
User avatar

Joined: 26 Apr 2005 12:00
Posts: 715
Location: PARIS
Hi

Did you try to launch your script with same user ?
Anyhow verify if all environment variables are available launching your script thru Control-M


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+02:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited
The site created by Franck YOT. Images, logo, content and trademarks about Control-M products are property of BMC Software.
All the comments are property of their posters. Images, logo, content and design are © copyright by Scheduler-Usage.com. All Rights Reserved